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C H A P T E R 
 

1 
Introduction 

  

What is the Installation Guide? 

The Installation Guide is part of the overall Wavevue manual set illustrated below.  Its purpose is to guide 
you through the process of installing Wavevue, performing an initial run to verify installation, and setting 
up user accounts.  Refer to the Application Level User’s Guide and various module User’s Guides for 
detailed instructions on using Wavevue to perform measurements. 
  
 

 

Figure 1.  Manual Set Overview 
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Who should read the Installation Guide? 

The Installation Guide is intended to be used by IT personnel or the user who will be acting as the system 
administrator for Wavevue.  No measurement expertise or experience is required to get Wavevue 
installed and running.  Prior experience with cabling GPIB test systems will be helpful in setting up an 
Instrument Edition of Wavevue to perform testing, however. 

What will I learn from the Installation Guide? 

The installation Guide will lead you through the following phases of Wavevue installation: 
 

Table 1.  Installation Guide Task Overview 

Chapter Title Description 

2 
Getting Ready to Install 
Wavevue 

· Checking the Wavevue box contents 
· Installing a GPIB interface and software 
· Configuring other third party applications for Wavevue 

compatibility 

3 
Installing Wavevue for the 
First Time 

· Installing the Wavevue software 
· Installing the software license key 
· Overview of the Wavevue directory structure 

4 Starting Wavevue 

· Running Wavevue to verify the installation 
· Introducing the login window 
· Introducing the Open Project window 
· Verifying GPIB communications 
· Managing user accounts 

5 Upgrading Wavevue 
· Installing complete Wavevue upgrades 
· Installing patch Wavevue upgrades 
· Installing software license key upgrades 

 

Where do I go from here? 

Once you are comfortable that the Wavevue installation was successful, you should proceed to the 
Application Level User’s Guide and various module User’s Guides for detailed instructions on how to use 
Wavevue to perform measurements. 
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Notational Conventions 

Throughout this manual, various symbols will be used to identify important information that may affect 
software operation, user safety, or device safety. This manual uses the following conventions: 
 

Table 2.  Notational Conventions 

Symbol Description of Symbol 

 

WARNING is used to indicate the presence of a hazard which can cause severe 
personal injury, death, or substantial property damage if the warning is 
ignored. 

 

DANGER is used to indicate the presence of a hazard that will cause severe 
personal injury, death, or substantial property damage if the warning is 
ignored. This includes situations that may cause damage to hardware via 
electrostatic discharge (ESD). 

 

CAUTION is used to indicate the presence of a hazard which will or can cause 
minor personal injury or property damage if the warning is ignored. 

 

NOTE is used to indicate important information about the product that is not 
hazard related. This might include useful tips regarding ease of use or 
possible errors. 

 

  

The symbol indicates a World Wide Web address. 

Manual Conventions 

· Throughout the manual set, the words Window, Screen and Form may be used interchangeably 
to refer to the depiction of a user interface. Unless otherwise noted, there is no difference 
between these terms. 

· The following format is used throughout the manual set to indicate the sequence of menu 
navigation, where each “>” indicates another menu level: 
Configure > Calibrations > S-Parameters 

 

WARNING 

DANGER 

CAUTION 

NOTE 

WWW 
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C H A P T E R 
 

2 

Getting Ready to Install 
Wavevue  

  

 
 
The Wavevue install should be straightforward and trouble-free if you take a few minutes to collect 
everything you need and verify all system requirements prior to starting.  Since Wavevue interacts and 
relies on other software for some of its functionality, it’s a good idea to verify those other programs 
independently of Wavevue.  In the unlikely event of problems, that will greatly simplify the task of 
troubleshooting. 

Gathering materials 

Most of the material you will need to install Wavevue is contained in the box you purchased.  The only 
additional material required is a GPIB interface card if you are running the Instrument Edition of 
Wavevue. Refer to the picture below to verify the contents of the box.  Opening the front cover should 
reveal the Wavevue Installation CD and also the software license key.  In the back section of the box, you 
should find the License Agreement as well as all of the manuals you will need, including this one. 
 

 

Figure 2.  Wavevue box 
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Checking the system requirements 

Wavevue is a high-end software product and requires a high performance computer to perform to its full 
potential.  Verify that your computer meets at least the minimum requirements and preferably the 
recommended requirements to get the best results from your software investment. 
 

 

Wavevue is designed to be usable at 1024x768 resolution for use on laptop 
computers, but it is recommended that you run it at the highest resolution 
supported by your video card and monitor. 

 

Table 3.  System Requirements 

Item Minimum1 Recommended1 

Video Monitor 17” CRT or 15” LCD 19” CRT or 18” LCD 

Video Card1 
 

1280 x 1024 @75Hz min 
16 bit color 

1600 x 1200 @ 75Hz 
32 bit color 

Memory 128MB 256MB 

Processor Type Pentium III Pentium IV or above 

Processor Speed 600MHz 1.8GHz 

Hard Disk Drive 4.0GB 20.0GB 

CD-ROM 4X 48X 

Network Card 10BaseT 100BaseT 

Mouse 
Keyboard 
USB Port 

Required 
Required 
Required 2 

Required 
Required 
Required 2 

Operating System 
 

Windows 2000 
(Instrument or Office Edition) 
Windows XP, ME, 98 
(Office Edition only) 

Windows 2000 
(Instrument or Office Edition) 
Windows XP, ME, 98 
(Office Edition only) 

GPIB Card  
(Instrument Edition Only) 

National Instruments ISA or PCI 
Hewlett Packard 83250A 

National Instruments PCI 
Hewlett Packard 83250A 

1 These specifications will change as technologies change.  Please refer to the Microvue website for the most up to 

date system requirements and recommendations. 
2 Required for software license key 

NOTE 
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Configuring a GPIB interface 

Although Wavevue supports other modes of communication, most test instruments are controlled via a 
GPIB interface.  In order for Instrument Editions of Wavevue to control instruments, you must have a 
GPIB interface installed in your computer. 
 

 

For Office Edition installations, skip to the next step.  Office Edition Wavevue 
will not control test instruments, even if a GPIB interface is installed in the 
computer. 

 

Installing the card 

Wavevue supports National Instruments and Agilent GPIB interface cards.  Refer to the 
documentation that came with your computer for instructions on opening the case.  Refer to the 
manufacturer’s GPIB interface documentation for detailed installation instructions. 
 

 

Dangerous voltages may be exposed when you open the computer 
case.  Always unplug the computer before attempting to remove the 
cover. 

 

 

PC interface cards contain static sensitive components.  Observe 
customary precautions for handling static sensitive material when 
handling the card. 

Installing the NI software 

National Instruments provides two different levels of driver software with their interfaces.  Wavevue 
uses the low-level commands in the NI 488.2 software.  It does not use the higher level commands 
contained in the NI VISA software, so there is no need to install this software.  Follow the 
manufacturer’s instructions to install the NI 488.2 software on your computer. 
 

 

Earlier versions of NI 488.2 software had some stability problems that 
occasionally cause Wavevue and other application programs to crash.  
It is highly recommended that you upgrade to NI 488.2 version 2.0 or 
later. 

 

NOTE 

CAUTION 

WARNING 

NOTE 
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Configuring the NI software 

The default settings of the NI 488.2 software should be compatible with Wavevue.  Double-checking 
the settings is a good idea, though.  It also verifies the GPIB hardware and software installation, 
independent of Wavevue. 
 

1. Run the NI Measurement and Automation Explorer (MAX). 
2. Click the Devices and Instruments icon to expand the tree view. 
3. Click the icon for your interface card (GPIB0 by default) and then click the Properties icon.  

The window shown below will appear: 
 

 

Figure 3.  NI GPIB 488.2 Configuration 

 
4. Note the Primary address setting for later use configuring Wavevue instruments. 
5. Make sure that the System Controller checkbox is checked. 
6. Close the GPIB Configuration window and exit the Measurement and Automation Explorer. 

 

Installing the Agilent software 

The Agilent GPIB software is not separated into two distinct layers like the National Instruments 
software.  Refer to the manufacturer’s documentation for detailed instructions on installing the VISA 
software. 

Configuring the Agilent software 

The default settings for the GPIB software should be compatible with Wavevue.  Refer to the 
manufacturer’s documentation to verify them, however. 
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Configuring Nucleus for Wavevue compatibility 

A measurement system which employs both Wavevue and Nucleus can be configured in two different 
ways.  The figure below illustrates the Shared Configuration and the Remote Configuration.  Refer to the 
appropriate section below to verify that your Nucleus settings are correct for the configuration you plan 
to run. 
 

 

Figure 4.  Wavevue Remote Control Configurations 

Shared Configuration 

When Wavevue and Nucleus reside on the same computer, Wavevue communicates with Nucleus 
via a dynamic link library (DLL) that employs Dynamic Data Exchange (DDE).  In this configuration, 
you must ensure that Nucleus’ GPIB communication is disabled.  When Nucleus has GPIB 
communication enabled, it polls the GPIB bus very frequently checking for commands.  This 
interferes with Wavevue’s ability to communicate with GPIB test instruments and effectively renders 
Wavevue unusable for measurement.  Refer to the section below which corresponds to your revision 
of Nucleus to verify that it is set up property to be compatible with Wavevue. 

Nucleus 2.6 

1. Select Start > Cascade Microtech > Nucleus 2.6 > Hardware Configuration.  The hardware 
configuration utility will open with an empty display.  Click the Open icon and select 
“default.cfg” and the display should appear as below: 
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Figure 5.  Nucleus 2.6 Hardware Configuration 

 
2. Verify that the highlighted driver, “Communications: DDE Server” appears on the list and 

that the driver “Communications: GPIB” does not appear. 
 

3. If the settings are not correct, click the System Config icon and change the settings to match 
the window below: 

 

 

Figure 6.  Remote Communications Settings 

 
4. Click OK when done, then click the Save icon and save the changes to “default.cfg”.  Select 

File > Exit to exit the Hardware Configuration application. 

Nucleus 2.5 

1. Select Start > Cascade Microtech > Nucleus 2.5 > SystemMgr.  The System Manager will 
start, but will be in a minimized state.  Look for the SystemMgr icon in the system tray.  
Right click it and select Maximize and the System Manager window should fill the screen. 
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2. Select File > Open and open “default.cfg”.  The Component List and Status window should 
now appear as below: 

 

 

Figure 7.  Nucleus 2.5 Component List 

 
3. Verify that the highlighted driver, “Communications: DDE Server” appears on the list and 

that the driver “Communications: GPIB” does not appear. 
 

4. If the settings are not correct, click Components > Add to add the “Communications: DDE 
Server” driver and Components > Delete to remove the “Communications, GPIB” driver. 

 
5. Once the settings are correct, click the Save icon and save the changes to “default.cfg”.  

Select File > Exit to exit the System Manager. 

Remote Configuration 

When Wavevue and Nucleus reside on separate computers, Wavevue communicates with Nucleus 
via GPIB.  In this configuration, you must ensure that Nucleus’ GPIB communication is enabled.  
Refer to the section below which corresponds to your revision of Nucleus to verify that it is set up 
property to be compatible with Wavevue. 

Nucleus 2.6 

1. Select Start > Cascade Microtech > Nucleus 2.6 > Hardware Configuration.  The hardware 
configuration utility will open with an empty display.  Click the Open icon and select 
“default.cfg” and the display should appear as below: 
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Figure 8.  Nucleus 2.6 Hardware Configuration 

 
2. Verify that the highlighted driver, “Communications: GPIB” appears on the list.  It doesn’t 

matter whether the driver “Communications: DDE Server” appears or not. 
 

3. If the settings are not correct, click the System Config icon and change the settings to match 
the window below: 

 

 

Figure 9.  Remote Communications Settings 

 
4. Click OK when done, then click the Save icon and save the changes to “default.cfg”.  Select 

File > Exit to exit the Hardware Configuration application. 

Nucleus 2.5 

1. Select Start > Cascade Microtech > Nucleus 2.5 > SystemMgr.  The SystemMgr will start, 
but will be in a minimized state.  Look for the SystemMgr icon in the system tray.  Right click 
it and select Maximize and the SystemMgr window should fill the screen. 
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2. Select File > Open and open “default.cfg”.  The Component List and Status window should 
now appear as below: 

 

 

Figure 10.  Nucleus 2.5 Component List 

 
3. Verify that the highlighted driver, “Communications: GPIB” appears on the list.  It doesn’t 

matter whether the driver “Communications: DDE Server” appears or not. 
 

4. If the settings are not correct, click Components > Add to add the “Communications: GPIB” 
driver. 

 
5. Once the settings are correct, click the Save icon and save the changes to “default.cfg”.  

Select File > Exit to exit the SystemMgr. 
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Configuring WinCal for Wavevue compatibility 

WinCal and Wavevue both control test instruments via the GPIB interface in the computer.  However, 
they don’t directly communicate with each other, so there are no special settings required to make 
WinCal compatible with Wavevue. 

 

 

 

Configuring Microsoft Office for Wavevue compatibility  

Wavevue can export reports to Microsoft Word.  This function requires Word to have the Windows 
Metafile graphics filter installed.  Early versions of Word required this filter to be selected as part of a 
custom installation, but all later versions include it by default.  So there are no special settings required 
to make Word compatible with Wavevue. 
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C H A P T E R 
 

3 

Installing Wavevue for the 
First Time 

  

 
 
Now that you have completed the pre-installation tasks, you are ready to actually install the Wavevue 
software.  This should be a very straightforward procedure.  There are currently no installation options 
other than the target directory, so you don’t have to worry about getting all of the components installed 
correctly. 
 

 

The figures in this section were generated in Windows XP and may appear 
slightly different in other versions of Windows.  But the functionality will be 
the same even if they look slightly different. 

 

Installing the software 

 

Do not install the Wavevue software license key on your computer prior to 
installing the Wavevue software.  Doing so may cause the last step of the 
installation to fail and Wavevue will be unable to read the software license 
key. 

 

 

If you are installing a DEMO version of the software, the installation 
procedure is exactly the same as for a full-function copy.  The only difference 
you will see is on start-up, which will be detailed in the next chapter.  

 
 
Insert the Wavevue Measurement Studio CD into your computer.  The install program should 
automatically start, leading you through the installation.  If for some reason the install program doesn’t 
automatically start, use Windows Explorer to navigate to the CD drive and manually run “Setup.exe”. 
 
A couple of status windows may pop up for a few moments informing you of the status of Windows 
Installer preparing to install the program.  Once they have completed, the Welcome window will appear: 
 

NOTE 

NOTE 

NOTE 
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Figure 11.  Installer Welcome Window 

 
Click Next to proceed.  The License Agreement window will appear next: 
 

 

Figure 12.  Installer License Agreement Window 

 
You must accept the license agreement to continue the installation process.  Select “I accept” and click 
Next to continue.  The Customer Information window will appear: 
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Figure 13.  Installer Customer Information Window 

 
Enter your user name and company name in the fields and click Next.  The Destination Folder window 
will appear: 
 

 

Figure 14.  Installer Destination Folder Window 

 
By default, Wavevue will install to “C:\Program Files\Microvue\Wavevue”.  Most customers will keep this 
setting, but you can change the location with no problems if you prefer a different location.  Click Next to 
continue.  The Ready window will appear next, summarizing all of the information entered so far: 
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Figure 15.  Installer Ready to Install Window 

 
Verify that all of the information display is correct and click Install to continue.  The installer will copy all 
of the required files to your computer.  This may take several minutes.  When the process is complete, 
the Install Finished window will appear: 
 

 

Figure 16.  Installer Finished Window 

 
Click Finish to continue.  This window will not disappear yet, but you will see a small status window 
appear for a few seconds indicating that the hardware driver for the license key is being installed.  When 
that process is complete, a confirmation dialog will appear: 
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Figure 17.  HASP Key Driver Finished Dialog 

 
Click OK to complete the installation process for Wavevue.  This window and the previous window should 
both disappear.  The software installation is now complete.  

Installing the hardware key 

Insert the Wavevue license key into any available USB port on your computer.  It will automatically be 
recognized and configured.  Wavevue reads the license key on start-up and frequently re-reads it while 
running, so you must leave it installed in the USB port the entire time the program is running. 
 

 

Figure 18.  Wavevue License Key 
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Understanding Wavevue directory structure and files 

Along with the main Wavevue executable program, the installation also includes a large number of 
system files required for operation.  The tables below describe where these files are located and what 
they do. 
 

 

Unless otherwise noted, all paths are relative to the folder specified by the 
Destination Folder window during the installation process. 

System Files 

Wavevue system files include graphics for the various user interfaces and configuration files.  They 
should not be altered in any way by the user or Wavevue may cease to function.  They will also all be 
overwritten by a complete Wavevue upgrade, so any changes to them will be lost. 

 

Table 4.  Wavevue System Files 

Directory Content 

Application Utilities Miscellaneous user interface graphics files 
Wavevue sound files 
HASP key driver install program 

Calibration Data System calibration data files.  Note that these are different 
from measurement calibration data files. 

Corporate Logos Cascade and Microvue logo interface graphics files 

Device Tags Configuration files which define the Meas Info user interface 
for Wavevue 

Device Types Device definition files for all of the built-in standard Wavevue 
devices 

Device Types\Device Bitmaps User interface graphics files for all of the built-in standard 
Wavevue devices 

Help Files The on-line manual and additional Wavevue help files 

Local Environment Preference file which stores the toolbar settings for Wavevue 
as well as the locations of Office components and other 
miscellaneous application settings. 

Program The Wavevue executable file 

Standard Projects The directory tree under this folder contains all of the built-in 
Wavevue standard projects.  These should be used as a 
starting point to build user projects, but not edited directly, as 
they are overwritten in each successive Wavevue upgrade 

Toolbars Configuration file used to build the Wavevue toolbars. 

Toolbars\Icons 16 by 16 Graphics files for the toolbars in 16x16 bit mode 

Toolbars\Icons 32 by 32 Graphics files for the toolbars in 32x32 bit mode 

 

NOTE 
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User Files 

Wavevue also builds a directory structure where various user files are stored.  They may be added 
and altered and will not be affected by subsequent Wavevue upgrades. 

 

Table 5.  Wavevue User Files 

Directory Content 

Accessory Data Power sensor cal tables,  noise source ENR tables, etc. 

Device Tags Wavevue creates a default “device tags.txt” file in this directory 
which is overwritten by each software upgrade.  You can add 
additional files to define custom Meas Info configurations. 

Device Types Wavevue stores the standard device type definition files here.  
Additional user files may be added to this directory to define 
custom device types.  The standard device types will be 
overwritten by each software upgrade, but the custom device 
types should be unaffected. 

Device Types\Device Bitmaps Wavevue stores the standard device type graphics files here.  
Additional user files may be added to this directory to define 
custom device types.  The standard device types will be 
overwritten by each software upgrade, but the custom device 
types should be unaffected. 

Standard Projects Wavevue stores the standard projects in the directory structure 
below this folder.  You are allowed to edit these projects, or 
store additional projects here, but it strongly discouraged, since 
you will lose any changes each time you install a software 
upgrade. 

User Accounts The User Name and Password list 
User Preference and Default Directory files for each user 
(only when run in Local Login mode) 

C:\Wavevue Data Wavevue creates this directory and uses it as the default for all 
project setup and data files, unless otherwise specified. 
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Troubleshooting 

If you run into trouble during the installation, check the following questions and answers first.  If those 
don’t solve your problem, please refer to the Getting Help chapter at the end of this manual for further 
assistance. 
 

The Wavevue installation didn’t automatically start when I inserted the CD into my 
computer. 

The installation CD should automatically run when inserted, but if it doesn’t, you can still start the 
installation process manually.  Use Windows Explorer to navigate to the CD drive.  Double-click 
“Setup.exe” and the installation process will begin. 

 

Windows can’t read the installation CD. 

All Wavevue installation CD’s are tested prior to leaving the factory.  However, it’s possible that the 
CD was damaged during shipping or unpacking.  In this case, please contact the factory for a 
replacement CD. 

 

The installation process seemed to hang on the last step while trying to install the HASP 
driver. 

This can happen if the software license key is attached to the USB port while trying to install 
Wavevue.  If necessary, re-boot the computer.  Use Control Panel > Add or Remove Programs to un-
install Wavevue, and repeat the installation with the software license key removed. 

 



Wavevue Measurement Studio Installation Guide 

 
Chapter 5:  Upgrading Wavevue  ·  23 

C H A P T E R 
 

4 
Starting Wavevue 

  

 
 
At this point, you should have successfully completed installing Wavevue.  Starting the program and 
performing a few simple tasks is the best way to verify that everything went well. 
 

 

If you are running a DEMO copy of Wavevue, the first window you will see is a 
notice of the DEMO status and a summary of how many days and runs you 
have remaining before the DEMO expires. 

Logging into Wavevue 

Double click the Wavevue desktop icon to start the program.  The first window that appears is the 
Welcome window: 
 

 

Figure 19.  Wavevue Welcome Window 

NOTE 
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The Welcome window displays some useful information about Wavevue and also allows you to log into 
the program.  Wavevue requires you to log in so that the system administrators can implement different 
user access levels, and also so that different users can maintain different preferences. 

Default passwords 

On a new installation, Wavevue creates two user accounts – System Administrator and Guest User.  
The default passwords for these accounts are shown in the table below.  Note that Wavevue 
passwords are case-sensitive, so make sure the caps lock key isn’t on. 
 

Table 6.  Default Account Passwords 

User Name Password 

System Administrator admin 

Guest User <no password> 

 
Wavevue also remembers the last user to log in and pre-selects the user on the next run.  On the 
initial run, the default user is System Administrator.  Type the password in the field as shown below 
and click Next to continue. 
 

 

Figure 20.  Welcome Window Login Detail 

 

 

Since the default System Administrator password is the same for all 
Wavevue installations, you may wish to change it for security purposes 
after the initial login.  Refer to Changing passwords later in this chapter 
for detailed instructions. 

 

NOTE 
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License list display 

The list of modules licensed by the license key is displayed in the Welcome window as well.  The 
blue display will show your license key number as well as each available licensed module.  If you do 
not see licenses for all of your expected modules, double-check that you installed the correct 
software license key.  If you still feel that you are missing licenses, refer to the Getting Help chapter 
at the end of this manual to contact the factory.  
 

 

Figure 21.  Welcome Window License Info Detail 

Local vs. Network account management 

Wavevue supports two different user account management schemes.  In the default LOCAL scheme, 
a separate user name and password list and user preference files are maintained on each machine.  
The system administrator can optionally set up a NETWORK login scheme where the user list and 
user preference files reside on a central network drive.  This was, the user preferences follow each 
user from machine to machine around the enterprise and the administration task is simplified on 
multi-seat installations.  
 

 

Figure 22.  Welcome Window Network Detail 
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Searching for complementary applications 

Wavevue is able to export reports to Microsoft Word.  In order to be able to automate Word, it needs 
to know its location on the computer hard drive.  Wavevue also uses Adobe Acrobat Reader to 
display the on-line manuals.  Again, it needs to know where the Acrobat Reader resides on the hard 
drive.  Since this search can be a little time-consuming, Wavevue performs the search once on the 
initial run and records the locations in the environment file.  The search is performed for the 
following applications: 
 
q Microsoft Word 
q Microsoft Excel 
q Microsoft PowerPoint 
q Adobe Acrobat Reader 

 
If any of these applications are added to the computer after the initial Wavevue run, the search can 
be repeated by selecting Tools > Search for Office Applications… 

Simulation lock warning 

Office Editions of Wavevue always run in Simulation mode.  In this mode, you can run measurement 
scripts, but Wavevue doesn’t actually control any instruments.  Instead, it simulates measurement 
data.  This functionality exists to allow you to test out reports off-line during project creation without 
needing to tie up your expensive test stands.  Simulation mode is also available in Instrument 
Edition of Wavevue.  Click the Simulation icon on the auxiliary toolbar to toggle Simulation mode on 
or off. 
  
On start-up, Instrument editions of Wavevue search the hard drive for the driver files for GPIB 
interfaces.  If a recognized interface is found, Wavevue sends a low level GPIB command to do a 
quick check of the interface hardware.  If either the driver search or hardware test fails, the 
following message appears, and Wavevue will be locked into Simulation mode where GPIB access is 
no longer available. 
 

 

Figure 23.  Simulation Lock Warning Dialog 

 

This is not a normal operating condition.  When running Instrument 
Edition on a computer with a properly configured GPIB interface, you 
will never see this warning. 

 

NOTE 
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Creating a blank project 

Once all of the start-up checks are complete, Wavevue displays the Open Project window.  This 
window allows you to open a Standard project, or one of your own custom projects, or to start with a 
blank slate.  It is explained in much greater detail in the Application Level User’s Guide.  For this 
exercise, creating a new project is the most efficient next step. 
 

 

Figure 24.  Open Project Window 

 
Click the New Project icon to select it, then click Next to continue. 
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Verifying GPIB communications 

 

This step only applies to Instrument Editions of Wavevue.  Office Editions are 
always in Simulation mode and don’t support GPIB communications. 

 
Wavevue includes a GPIB Scan tool to help with the task of configuring your GPIB test instruments.  This 
tool is also good for verifying GPIB communications in general.  In order to verify that your GPIB hardware 
and software is installed and configure properly, connect the computer to your test instruments using 
GPIB cables. 
 
From the main menu, select: Tools > GPIB Bus Scan…    The GPIB Scan window shown below will appear. 
 

 

Figure 25.  GPIB Scan Utility Window 

  
Make sure that the “GPIB Interface Addr” control is set properly to match your interface card, then click 
Scan Now.  After several seconds, the Scan Results grid is should be filled with information about any 
GPIB instruments detected.  Wavevue should detect any instruments on the GPIB bus, but it can only 
identify those that it has drivers for, and then only those that respond to the standard GPIB “*IDN?” 
query.  If the list of GPIB addresses detected corresponds to your suite of test instruments, you know 
that your GPIB setup is fine.  

NOTE 
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Managing user accounts 

In order to manage user accounts, you must be logged in as System Administrator.  From the main 
menu, select Tools > System Admin Functions…  The System Administration window shown below will 
appear.  
 

 

Figure 26.  System Administration Utility Window 

  

Adding users 

To add a new user account: 
 

1. Type the user name in the Name field 
2. Type the default password for the new user 
3. Select an access level 
4. Click the Add Account button 

 
The new username should be added to the list on the left. 
 

 

Different access levels are not yet implemented in Wavevue.  The 
control is still implemented to allow it to be added in a future revision. 

 

NOTE 
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Changing passwords 

The System Administrator can change any account password.  To do this: 
 

1. Select the username from the list on the left 
2. Type the new password 
3. Click the Set button next to the Password field 

 
The account password will be reset. 
 
All Wavevue users can change their own password.  To do this, select the password icon from the 
toolbar, or select Tools > Change User Password…  The password window shown below will appear.  
 

 

Figure 27.  Change Password Window 

 
Type your current password in the first field, and the new password twice in the next two fields.  
Click OK to set the new password. 

Security considerations 

Wavevue stores the account names and encrypted passwords in a text file in the User Accounts 
directory created during installation.  The encryption method is one-way, so passwords cannot easily 
be decrypted.  But no encryption scheme is unbreakable, and the one employed by Wavevue is no 
exception. 
 

 

It is highly recommended that a user’s Wavevue password not be the 
same as their Windows and other company account passwords.  That 
way if the Wavevue password is compromised, minimal harm is done. 

 

NOTE 
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Exiting Wavevue 

At this point, we have verified that the installation completed properly and that Wavevue is running 
correctly.  You should now proceed to the Application Lever User’s Guide for more detailed descriptions 
of all of the features available in Wavevue. 
To exit Wavevue, click the Exit icon on the main toolbar, or select File > Exit Program… from the main 
menu.  The Goodbye window shown below will appear. 
 

 

Figure 28.  Exit Wavevue Confirmation Window 

 
Since the empty project that you created isn’t worth saving, click the Exit without save button.  Wavevue 
will exit back to the operating system. 
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Troubleshooting 

If you run into trouble during this initial run, check the following questions and answers first.  If those 
don’t solve your problem, please refer to the Getting Help chapter at the end of this manual for further 
assistance. 
 

When I try to start Wavevue, I get a message about No License Key Detected. 

There are several different possible causes of this error: 
 
1)  The license key isn’t securely installed on the computer. 
Wavevue checks for the license key on start-up and again on a frequent basis while running, so the 
key must stay attached to the computer the entire time Wavevue is running.  Verify that the key is 
securely inserted into the USB port and that the LED is lit. 
 
2)  The USB ports on the computer aren’t enabled in the BIOS. 
This is fairly unusual, but occasionally the USB ports may not have been enabled by whoever 
configured the computer.  Refer to your owner’s manual to verify that the USB ports are enabled.  
You may also want to insert a non-Wavevue USB device and verify that it functions correctly on the 
selected port. 
 
3)  The USB license key driver didn’t install properly during the Wavevue installation procedure. 
If the key is inserted properly and the LED is lit, but you still get the message, you can try manually 
re-installing the driver software.  First remove the license key from the USB port.  Click Start > Run, 
then click the Browse button.  Navigate to the Application Utilities folder in the Wavevue install 
directory, then select “HINSTALL.EXE”.  Add –i to the end of the string.  The string in the Open field 
will typically look like: 
 
“C:\Program Files\Microvue\Wavevue\Application Utilities\HINSTALL.EXE” –i 
 
Click OK to run the utility to re-install the license key driver software.  After a few seconds, it should 
responds with an Installation Successful window. 
 
4)  The license key is defective or broken 
All license keys are verified prior to leaving the factory.  In the unlikely event that one is damaged 
during shipment or unpacking, please refer to Chapter 6 and contact the factory for a replacement 
key. 

 

When I start Wavevue Instrument Edition, I get a message about being locked into 
Simulation mode. 

This message is generated because Wavevue failed to detect either GPIB driver software or the 
GPIB card hardware test failed on start-up.  Verify that your computer does have a GPIB interface 
installed and that the driver software is installed properly.  You may also want to use a non-Wavevue 
application such as National Instruments Test and Measurement Explorer to verify GPIB 
functionality independently of Wavevue. 
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5 
Upgrading Wavevue 

  

 
 
Your support agreement for Wavevue includes unlimited free software upgrades.  Wavevue is updated 
on a regular basis as bugs are found or new features are added. 

Where to find upgrades 

The latest versions of Wavevue are always available on the Microvue web site: 
 

http://www.microvueinc.com/upgrades.htm 
 
Upgrades fall into two categories – Complete upgrades and Patch upgrades.  Complete upgrades involve 
uninstalling your existing version of Wavevue and performing a complete new installation.  Patch 
upgrades simply replace the Wavevue executable file but don’t affect all of the rest of the installed 
Wavevue files. 

Installing a complete upgrade 

A complete upgrade is very similar to your initial installation of Wavevue.  The main difference is that you 
download it from the website and install it from an archive file rather than an installation CD. 

Installation overview 

Uninstalling your current version of Wavevue will remove all of the Wavevue System files specified in 
Table 4 in Chapter 3.  New versions of all of these files will then be added during the installation 
process.  All of the User files specified in Table 5 in Chapter 3 should be unaffected by the upgrade. 
 
If you are unsure about the status of any files, it would be wise to back them up to a CD-R or 
another folder on the hard drive before proceeding with the upgrade installation. 

http://www.microvueinc.com/upgrades.htm
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Installation steps 

 

Remove the Wavevue software license key from your computer prior to 
running the installation program.  Failure to do so may cause the last 
step of the installation to fail and Wavevue will be unable to read the 
software license key.  

 
1. Download the complete upgrade file from the Microvue web site. 
2. Unzip the complete upgrade file into a temporary file on the target computer. 
3. Uninstall the existing version of Wavevue using System Tools > Add/Remove Software. 
4. Run Setup.exe from the temporary file on the target computer. 

 
A couple of status windows may pop up for a few moments informing you of the status of Windows 
Installer preparing to install the program.  Once they have completed, the Welcome window will 
appear: 
 

 

Figure 29.  Installer Welcome Window 

 
Click Next to proceed.  The License Agreement window will appear next: 
 

NOTE 
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Figure 30.  Installer License Agreement Window 

 
You must accept the license agreement to continue the installation process.  Select “I accept” and 
click Next to continue.  The Customer Information window will appear: 
 

 

Figure 31.  Installer Customer Information Window 

 
Enter your user name and company name in the fields and click Next.  The Destination Folder 
window will appear: 
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Figure 32.  Installer Destination Folder Window 

 
By default, Wavevue will install to “C:\Program Files\Microvue\Wavevue”.  You can change this 
location if you like.  You should install it in the same location as the previous version of Wavevue, 
however.  Click Next to continue.  The Ready window will appear next, summarizing all of the 
information entered so far: 
 

 

Figure 33.  Installer Ready to Install Window 

 
Verify that all of the information display is correct and click Install to continue.  The installer will copy 
all of the required files to your computer.  This may take several minutes.  When the process is 
complete, the Install Finished window will appear: 
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Figure 34.  Installer Finished Window 

 
Click Finish to continue.  This window will not disappear yet, but you will see a small status window 
appear for a few seconds indicating that the hardware driver for the license key is being installed.  
When that process is complete, a confirmation window will appear: 
 

 

Figure 35.  HASP Key Driver Finished Dialog 

 
Click OK to complete the installation process for Wavevue.  This window and the previous window 
should both disappear.  The software installation is now complete.  Install your hardware key back 
on the computer and you are ready to run the upgraded version of Wavevue. 
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Installing a patch upgrade 

A patch upgrade simply replaces the Wavevue executable file on your computer without affecting the 
rest of the Wavevue installation. 

Installation overview 

The only file that will be affected by a patch upgrade is the Wavevue executable program. 

Installation steps 

1. Download the patch upgrade file from the Microvue web site. 
2. Unzip the patch upgrade file into the “Program” folder in your Wavevue installation directory 

structure. 
3. Right click the Wavevue icon on the Desktop and change the Properties to link to the new 

executable file. 
4. Right click the Wavevue Start menu icon and change the Properties to link to the new executable 

file. 
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Installing additional module licenses 

Every installation of Wavevue Measurement Studio contains all of the available measurement modules.  
Use of the modules is enabled by the license codes stored in the Wavevue license key.  License keys can 
be remotely upgraded when additional module licenses are purchased without needing to be returned to 
the factory. 

Installation overview 

No files are affected by a module license upgrade.  Only the software license key is affected.  Note 
that license upgrade programs are key-specific, however, and will only work on the specific key that 
they are coded to. 

Installation steps 

 

The Wavevue license key must be installed in the computer for the 
license upgrade program to re-write it. 

 

 
1. Copy the license upgrade program to the target computer. 
2. Unzip the license upgrade file into a temporary file. 
3. Run the license update program. 

 
The license key upgrade process takes less than a second, and a confirmation window appears 
when the process has completed. 

Verifying new licenses 

Run Wavevue and check the Welcome window to make sure that the new licenses now appear in 
the license display as shown below: 
 

 

Figure 36.  Welcome Window License Info Detail 

NOTE 
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. 
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6 
Getting help 

  

Where to get more information 

 
If you purchased your Microvue product from a third-party vendor, you can contact that vendor for 
service and support.  Otherwise you may contact Microvue directly as shown below.  Requests for sales, 
service, and technical support information will receive a prompt response. 
 
  

· Telephone: (978)-251-0456 
· FAX:  (978)-926-0514 
· e-mail:  support@microvueinc.com 

 
 
 

 

When sending e-mail for technical support, please include information about 
both the hardware and software, plus a detailed description of the problem, 
including how to reproduce it.  Be sure to include all project files associated 
with the issue in order to expedite support. 

NOTE 
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